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Known Error: Microsoft Office Applications have license/activation errors on macOS

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4.0 - Updated on 2024-09-25 by David Schwartz

3.0 - Updated on 2024-09-25 by David Schwartz

2.0 - Updated on 2024-09-25 by David Schwartz

1.0 - Authored on 2023-12-01 by David Schwartz

Description

Users are unable to edit Microsoft Office documents due to licensing errors on macOS. This occurs when Office was previously using the campus volume license key. Errors begin after the 16.79.1 (Build 23111614) November 17, 2023 Microsoft Office update. User must change to a named user license to correct.

Workaround

Step 1: Check or Activate your Microsoft 365 license at:

https://sites.google.com/berkeley.edu/microsoft-365-activation/home

When the Activation Info tab reads "Microsoft 365 Apps is activated for you" your license is ready to use

Microsoft 365 Apps is activated for you

Step 2 (three methods):

Method 1: Update or Activate License in Word

  1. Launch Word
  2. Click "Microsoft Word" menu
  3. Select "Update License" or "Activate Microsoft 365"
  4. Sign into Microsoft with your @berkeley.edu email address 

 Activate Microsoft 365

Method 2: Run Self Service license reset offer

  1. Launch Self Service from the computer's /Applications folder
  2. Find "Reset Microsoft Office 365 License" and click "Remove"
  3. Launch Word and sign into Microsoft with your @berkeley.edu email address 

Reset Microsoft Office 365 License

Method 3: Reset login credentials via command line

  1. Quit all Office applications
  2. Copy the text below (triple click to select):
    defaults write com.microsoft.Word ResetOneAuthCreds -bool YES
  3. Open the Terminal app (it lives in the /Applications/Utilities folder, or just use Spotlight to search for it)
  4. Paste the clipboard and press return
  5. Launch Word and sign into Microsoft with your @berkeley.edu email address

defaults write

Cause

  • Users have Macs enrolled in JAMF before the September 30, 2022 change that defaulted to (the then-named) Office 365 for Enterprise
  • The existing Office 2019 Volume License continued to work on the Macs they used
  • Since they never logged into or Activated a Microsoft 365 installation, they were not included in the list of active users
  • Microsoft released an update that finally broke 2019 Volume Licensing, possibly last week's 16.79.1 (Build 23111614) November 17, 2023
  • After users claim a license and it becomes active they still can't sign in and/or Activate the apps on their Mac